iNode is installed on Ubuntu 18.04 operating system for SSL VPN authentication. After successful authentication, it was found that the terminal could not obtain an IP address.
Reproduce the issue and collect detailed logs from iNode, finding an error indicating port 50001 is occupied
Authxxx log error:
[2025-02-11 16:56:36] [ERROR] [0x7fcaca467700] [createSocket] Fail to bind Socket with this Port or IP: Port=50001, IP=NULL, err Address already in use.
[2025-02-11 16:56:36] [ERROR] [0x7fcaca467700] [processMain] create socket failed. set exit flag.
[2025-02-11 16:56:37] [ERROR] [0x7fcace971bc0] [main] quit!
Check port 50001 and confirm it is indeed occupied by another process
After terminating the process occupying port 50001, the authentication succeeded in obtaining the address.
Note: Ports 50001 and 50000 for iNode Xinchuang and macOS terminals are bound during client runtime for client process interprocess communications (IPC).